Delayed ACH Deposits

Incident Report for Alpaca

Resolved

This incident has been resolved.
Posted Jan 22, 2025 - 14:04 EST

Identified

We are currently experiencing some ACH deposit delays at this time. We are working to resolve the issue, and the deposits are expected to be posted by the end of the day. Thank you for your patience.
Posted Jan 22, 2025 - 12:12 EST
This incident affected: Accounts (Transfers).