The issue with ACH deposits from Friday, August 29, has been fully resolved. All pending transfers have been processed and are now correctly displayed in customer accounts.
We have confirmed that all funds are available and the customer impact is officially resolved.
Thank you for your patience and understanding while we worked to correct this issue.
Posted Sep 03, 2025 - 13:53 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted Sep 03, 2025 - 13:12 EDT
Investigating
We are currently investigating a technical issue affecting the display of some ACH deposits from Friday, August 29.
We want to assure you that the ACH transfers were successfully processed and the funds are in your account. The issue is with the display on our end, and you do not need to resubmit your deposit.
Our team is actively working to resolve the display issue as quickly as possible. We will provide another update once this has been corrected.
We apologize for any confusion or inconvenience this may have caused.
Posted Sep 03, 2025 - 13:11 EDT
This incident affected: Accounts (Transfers) and Broker API (broker.accounts.activities.get).