Stale closing price for 23-Jun due to upstream issue in providing the end of day closing price

Incident Report for Alpaca

Resolved

This incident has been resolved.
Posted Jun 24, 2025 - 02:06 EDT

Investigating

Our upstream (ICE) was unable to provide the end of day closing price for 23-Jun-2025 due to internal system issue. We are using previous day closing price (20-JUN-2025) for end of day calculation.
Posted Jun 24, 2025 - 00:09 EDT