Intermittent HTTP 500 errors across Multiple API's

Incident Report for Alpaca

Resolved

We are no longer observing errors and are marking this incident as resolved. Our team will continue monitoring to ensure stability. Please reach out if you experience any further issues
Posted Sep 11, 2026 - 13:25 EDT

Update

We are seeing signs of recovery and have not observed 500 errors recently. We are continuing to monitor the system to ensure everything remains stable.
Posted Sep 11, 2026 - 13:18 EDT

Update

We are continuing to monitor for any further issues.
Posted Sep 11, 2026 - 13:12 EDT

Monitoring

We are no longer seeing 500 errors over the past few minutes. Our team is continuing to monitor the system closely for any further issues.
Posted Sep 11, 2026 - 13:09 EDT

Update

This is being treated with the highest priority, and our team is actively working to restore normal service. We will share another update shortly.
Posted Sep 11, 2026 - 13:02 EDT

Investigating

We are seeing elevated errors on some endpoints, including order placement. Our team is working to restore service and will update you shortly.
Posted Sep 11, 2026 - 12:56 EDT
This incident affected: Live Trading API (Orders API) and Market Data Stocks REST API (https://data.alpaca.markets/v2/stocks/bars, https://data.alpaca.markets/v2/stocks/trades).