Account Funding Delay 02/26/2024
Incident Report for Alpaca
Resolved
This incident has been resolved.
Posted Feb 27, 2024 - 18:21 EST
Identified
ACH deposit/withdrawal and wire withdrawal initiations with an execution date of 02/26/24 have been delayed in transaction execution
Posted Feb 27, 2024 - 16:10 EST