End of day job to calculate balance and position is running longer than expected.

Incident Report for Alpaca

Resolved

We’ve resolved the earlier delay with our End-of-Day (EOD) processing for October 15th. All jobs have now completed successfully, end-of-day balances and positions are now available, and funds from yesterday's sales are also now available for withdrawal.
The delay was caused by a query that unintentionally blocked the EOD process. Once identified, it was safely terminated to allow processing to continue. We’re now reviewing the root cause and taking steps to help prevent similar issues in the future.
Posted Oct 16, 2025 - 06:44 EDT

Identified

We are creating the end of day balances and positions as of 15-OCT-2025
Posted Oct 16, 2025 - 04:41 EDT

Update

We are monitoring
Posted Oct 16, 2025 - 03:46 EDT

Investigating

This long running job would reconcile end of day balances and positions for 15-OCT-2025. This would also delay new account activation, margin call and end of day position and balance data.
Posted Oct 16, 2025 - 03:06 EDT
This incident affected: Accounts (New Account Onboarding).