trade api v1 incorrect timestamps

Incident Report for Alpaca

Resolved

This incident has been resolved.
Posted Apr 09, 2025 - 08:10 EDT

Monitoring

A fix has been implemented and we are monitoring the results.
Posted Apr 09, 2025 - 05:26 EDT

Identified

Accepted and pending events (anything with a 'pending_' prefix) currently have an incorrect timestamp, where the year part is 0 in the timestamp. We are actively working on the fix.
Posted Apr 09, 2025 - 04:57 EDT
This incident affected: Live Trading API (Trade Update Streaming).