Intermittent Database Connection Failure – Investigation Underway

Incident Report for Alpaca

Postmortem

A change in our monitoring system resulted in an alert erroneously firing indicating the database was down. In order to resolve this quickly the database was restarted, resulting in the outage.

Posted Oct 10, 2025 - 07:05 EDT

Resolved

This incident has been resolved.
Posted Oct 09, 2025 - 07:23 EDT

Investigating

On October 9, 2025, between approximately 09:48 UTC and 09:50 UTC, we experienced a short service disruption caused by an unexpected restart of production database. This may have resulted in connection errors for some users during this two-minute window.
The database systems recovered automatically, and all services have been operating normally since. Our engineering team is actively investigating the root cause to prevent a recurrence.
Posted Oct 09, 2025 - 07:21 EDT
This incident affected: Live Trading API (Account API, Orders API, Positions API, Assets API, Trade Update Streaming) and Accounts (Transfers, Bank Links, New Account Onboarding, Turbo Tax Integration).