Intermittent issue in get accounts & positions API endpoint

Incident Report for Alpaca

Resolved

This incident has been resolved.
Posted Aug 26, 2025 - 21:07 EDT

Monitoring

Fix is deployed and we are monitoring the performance.
Posted Aug 26, 2025 - 21:04 EDT

Identified

The issue was identified with one of the change that caused high DB connection usage, affecting API request to get timed out.
Posted Aug 26, 2025 - 21:04 EDT

Investigating

We are currently investigating this issue.
Posted Aug 26, 2025 - 20:49 EDT
This incident affected: Live Trading API (Account API, Positions API) and Broker API (broker.accounts.get).