Intermittent Errors on Broker API Account and Position Endpoints

Incident Report for Alpaca

Resolved

We have not observed any further issues since our last update, and service remains stable. We will continue to monitor the system closely, please do not hesitate to contact us if you experience any issues.
Posted Sep 09, 2026 - 04:02 EDT

Monitoring

Services have stabilized following intermittent errors on the GET account and positions endpoints. Our team remain in a state of monitoring. Thank you for your understanding.
Posted Sep 09, 2026 - 03:35 EDT

Identified

We've identified the issue, and the system has has recovered following a 7-minute window of impact (06:43–06:49 UTC). Our team continues to monitor the situation closely.
Posted Sep 09, 2026 - 03:14 EDT

Investigating

We are investigating intermittent elevated error rates and latency affecting the Broker API GET on Positions & Accounts requests. Some requests may experience transient failures. Our engineering teams are actively working to restore normal performance.
Posted Sep 09, 2026 - 02:56 EDT
This incident affected: Broker API (broker.trading.accounts.account_id.account.get, broker.trading.accounts.account_id.orders.get).