Incorrect market data sent via data streaming service

Incident Report for Alpaca

Resolved

This incident has been resolved.
Posted Aug 28, 2025 - 14:07 EDT

Investigating

We experienced a service degradation with our market data streaming service on August 28, 2025. A recent deployment caused a bug that resulted in duplicate and incorrect market data being sent to some users. Our engineering team identified the issue and deployed a fix to resolve the problem. The service is now operating as expected, and we will continue to monitor the system to ensure stability.
Posted Aug 28, 2025 - 14:07 EDT
This incident affected: Market Data Streaming API (wss://stream.data.alpaca.markets/v2/iex).