Resolved: Intermittent API Failures (10:15 -10:35 UTC)

Incident Report for Alpaca

Postmortem

On June 24, 2026, our platform experienced a brief period of elevated API errors between approximately 6:14 AM ET and 6:18 AM ET. An unusually high volume of inbound connections to our production API exceeded the capacity of a subset of our infrastructure, causing it to partially restart, briefly. Traffic redistributed automatically and services recovered within a few minutes.

There was no data loss and no impact to funds or positions. Customers may have seen intermittent timeouts or failed requests during the affected window; retries succeeded once capacity was restored.

Our engineering teams continued to monitor the platform through US market open to ensure stability and confirm successful resolution. We will continue to monitor closely as we know reliable API access is critical to your operations. Thank you for your patience as we restored services.

Posted Jun 25, 2026 - 10:53 EDT

Resolved

Earlier today between 10:15 to 10.35 UTC , some API requests experienced intermittent failures due to brief service instability. The issue has fully recovered and there is no ongoing impact. We are actively investigating the root cause and will follow up with a post-mortem.
Posted Jun 24, 2026 - 07:01 EDT
This incident affected: Live Trading API (Account API, Orders API) and Broker API (broker.accounts.get).