Possible delay in posting of wire deposits to accounts
Incident Report for Alpaca
Resolved
This incident has been resolved.
Posted Jul 16, 2024 - 09:18 EDT
Investigating
Due to an issue with our Bank, some clients that made deposits via wire transfer may experience a delay in the posting of the deposit to their Alpaca account. Alpaca currently expects that any deposits not posted on July 15th will post to accounts before the end of business of the 16th of July
Posted Jul 15, 2024 - 17:14 EDT