Delays in Trade Confirmation Emails

Incident Report for Alpaca

Resolved

This issue has been resolved. Please refer to your trade confirmations to view today's trades, once available. Thank you for your patience and understanding as we worked to implement a fix.
Posted Aug 03, 2026 - 19:34 EDT

Monitoring

A fix has been implemented and we are seeing emails being sent as normal. We will continue to monitor to ensure there are no more delays. Thank you for your continued patience.
Posted Aug 03, 2026 - 18:54 EDT

Identified

We have identified an issue with delays in trade confirmation/execution emails being sent. Order execution is still functioning as normal. Our team is working on implementing a fix for this issue. Thank you for your patience and we will update you as we work towards a resolution.
Posted Aug 03, 2026 - 18:40 EDT