Data historical endpoints give 50x error status
Incident Report for Alpaca
Postmortem

We apologize for the inconvenience this service disruption/outage may have caused. We would like to provide some information about this incident below. 

Incident Start: 11 January 2022 08:32 EST

Incident End: 11 January 2022 08:45 EST

Duration: 13 minutes

Affected Services and Features: historical data endpoints (except latest endpoints)

Description: Historical endpoints experienced 50x status responses during the mentioned period. From preliminary analysis, the root cause of the issue was related to a recent infrastructure change. Engineers rolled back the deployment to resolve the issue.

Customer Impact: A significant (~30%) percentage of requests returned 50x status for historical requests during the mentioned period.

Posted Jan 11, 2022 - 09:52 EST

Resolved
This incident has been resolved.
Posted Jan 11, 2022 - 08:45 EST
Monitoring
We're continuing to monitor the situation.
Posted Jan 11, 2022 - 08:40 EST
Investigating
We are currently investigating this issue.
Posted Jan 11, 2022 - 08:32 EST
This incident affected: Market Data Crypto REST API (https://data.alpaca.markets/v1beta1/crypto/{symbol}/trades, https://data.alpaca.markets/v1beta1/crypto/{symbol}/quotes, https://data.alpaca.markets/v1beta1/crypto/{symbol}/bars, https://data.alpaca.markets/v1beta1/crypto/trades, https://data.alpaca.markets/v1beta1/crypto/quotes, https://data.alpaca.markets/v1beta1/crypto/bars, https://data.alpaca.markets/v1beta1/crypto/{symbol}/trades/latest, https://data.alpaca.markets/v1beta1/crypto/{symbol}/xbbo/latest, https://data.alpaca.markets/v1beta1/crypto/{symbol}/quotes/latest) and Market Data Stocks REST API (https://data.alpaca.markets/v2/stocks/{symbol}/trades, https://data.alpaca.markets/v2/stocks/{symbol}/quotes, https://data.alpaca.markets/v2/stocks/{symbol}/bars, https://data.alpaca.markets/v2/stocks/{symbol}/snapshot, https://data.alpaca.marketes/v2/stocks/trades, https://data.alpaca.markets/v2/stocks/quotes, https://data.alpaca.markets/v2/stocks/bars, https://data.alpaca.markets/v2/stocks/snapshots, https://data.alpaca.markets/v2/stocks/{symbol}/trades/latest, https://data.alpaca.markets/v2/stocks/{symbol}/quotes/latest, https://data.alpaca.markets/v2/stocks/meta/conditions/{tickType}, https://data.alpaca.markets/v2/stocks/meta/exchanges).