Some Accounts Balances Update Are Delayed

Incident Report for Alpaca

Resolved

Balances update for affected accounts are completed. This issue is resolved.
Posted Sep 11, 2026 - 04:02 EDT

Investigating

We are experiencing a delay updating previous-day closing balances in the account API, which may affect daily gain/loss displays and reconciliation based on those values. We are working to complete the update and will provide confirmation once the affected balances are updated.

Estimated time to completion in 15 minutes
Posted Sep 11, 2026 - 04:00 EDT
This incident affected: Broker API (broker.trading.accounts.account_id.account.get).