Dividends not correctly deposited to accounts on 17 June
Incident Report for Alpaca
Resolved
This incident has been resolved. Users will see the original dividend with a $0 amount as cancelled, a reversing entry as cancelled and the new dividend as executed. If any questions please email support@Alpaca.Markets.
Posted Jun 17, 2022 - 09:36 EDT
Identified
Due to an internal issue where dividends were not correctly deposited to accounts on 17 June, we are manually posting these dividends before market open; any corresponding records will be generated during End of Day settlement.
Posted Jun 17, 2022 - 08:31 EDT
This incident affected: Accounts (Transfers).