Paper Trading: Portfolio Service Degradation

Incident Report for Alpaca

Resolved

Resolved: All affected services have returned to normal operation. API response times have normalized, and the portfolio graph is loading successfully on the dashboard. We will continue monitoring to ensure continued stability.
Posted Jul 24, 2026 - 01:02 EDT

Monitoring

We are seeing improvements following the database query optimization. API response times have returned to normal, and the portfolio graph is loading successfully on the dashboard. We continue to monitor the service closely.
Posted Jul 24, 2026 - 01:00 EDT

Identified

The underlying issue has been identified as an inefficient database query. The team has implemented performance optimizations, and we are monitoring the service to ensure stability and continued recovery.
Posted Jul 24, 2026 - 00:57 EDT

Update

Our team is actively investigating the issue and working to restore normal service as quickly as possible. We will provide further updates as they become available.
Posted Jul 24, 2026 - 00:23 EDT

Investigating

We have identified an issue affecting the Portfolio service in the paper trading environment, resulting in API errors and preventing the portfolio graph from loading in the dashboard. Our team is actively investigating the issue and working to restore normal service as quickly as possible. We will provide further updates as they become available.
Posted Jul 23, 2026 - 23:21 EDT
This incident affected: Dashboard.