As everything is fine now , Marking this incident resolved here.
Posted Jan 23, 2026 - 09:49 EST
Update
We are continuously monitoring and things are normal as of now.
Posted Jan 23, 2026 - 09:33 EST
Monitoring
After clearing the blocking database process, Overall response times are improving and moving back toward what we normally see.
Posted Jan 23, 2026 - 09:25 EST
Identified
Our engineering team has identified a few overloaded backend components and has restarted them and cleared a blocking database process to relieve pressure.
Posted Jan 23, 2026 - 09:21 EST
Investigating
We are currently experiencing increased response times due to elevated database connection usage. Our engineering team is actively investigating the issue, and we will keep you posted with updates here.
Posted Jan 23, 2026 - 09:12 EST
This incident affected: Broker API (broker.accounts.get, broker.trading.accounts.account_id.orders.get).