Issue with deposits and withdraws posting to some accounts (Wire & ACHs)
Incident Report for Alpaca
Resolved
This incident has been resolved.
Posted May 30, 2024 - 17:28 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 30, 2024 - 16:00 EDT
This incident affected: Accounts (Transfers).