KYCaaS partners - Delay in account review
Incident Report for Alpaca
Resolved
This incident has been resolved.
Posted Jul 22, 2024 - 14:23 EDT
Monitoring
Our KYC provider is facing an internet outage due to government actions in their country. As a result, KYCaaS partner accounts requiring manual review will experience delays. We anticipate a delay of 2-3 business days for reviewing these applications, as Alpaca will attempt to process them manually.
Posted Jul 19, 2024 - 12:21 EDT
This incident affected: Accounts (New Account Onboarding).