JNLCs and account opening services are down.

Incident Report for Alpaca

Postmortem

A critical PostgreSQL notification queue saturation event (99.99% usage) caused a partial service outage affecting account opening, journal processing (JNLC), and real-time event streaming for integrated partners. The notification queue reached maximum capacity due to a combination of factors which resulted in dropped notifications, failed API calls, and failure of dependent real-time event processing systems. All partner integrations relying on streaming events, and real-time updates were affected

Posted Aug 19, 2025 - 18:25 EDT

Resolved

This incident has been resolved.
Posted Aug 19, 2025 - 12:42 EDT

Update

We have synced services during the issue and recovery completed. If you have any questions and concerns on the affected services, kindly get in touch via support@alpaca.markets
Posted Aug 19, 2025 - 12:41 EDT

Monitoring

We have fixed the underlying root cause of the issue. We are recovering the services such as JNLCs, Instant funding now.
Posted Aug 19, 2025 - 12:19 EDT

Identified

Restart of DB instance completed. We are able to see the services are back to normal
Posted Aug 19, 2025 - 11:41 EDT

Update

We are restarting the DB instance causing the issue.
Posted Aug 19, 2025 - 11:36 EDT

Update

Suspect the issue was caused by a change posting excessive notification at DB level. We are restarting services as a part of recovery
Posted Aug 19, 2025 - 11:18 EDT

Update

We are continuing to investigate this issue.
Posted Aug 19, 2025 - 11:04 EDT

Update

We are seeing issues at database level affecting multiple services. Team is actively working on the recovery.
Posted Aug 19, 2025 - 11:04 EDT

Investigating

We are currently investigating this issue.
Posted Aug 19, 2025 - 10:44 EDT
This incident affected: Live Trading API (Account API, Trade Update Streaming) and Accounts (Transfers).