Issue in Portfolio History service for requests covering periods prior to June 1, 2026.

Incident Report for Alpaca

Postmortem

On July 21, 2026, between approximately 4:33 AM and 3:18 PM ET, Portfolio History requests covering periods before June 1, 2026 may have returned inaccurate or unavailable data while historical records were being restored.

Our engineering teams completed the historical data restoration and validated access to the affected information. Portfolio History is operating normally.

Posted Jul 21, 2026 - 17:13 EDT

Resolved

This incident has been resolved.
Posted Jul 21, 2026 - 15:43 EDT

Monitoring

We have fixed the issue.
Posted Jul 21, 2026 - 15:42 EDT

Update

Our team is working to make the data previous to June 1, 2026 available through Portfolio History. Thank you for your continued patience as we monitor progress. We expect this to be complete by 4pm ET.
Posted Jul 21, 2026 - 13:55 EDT

Identified

Our team is working to make the data previous to June 1, 2026 available through Portfolio History. Thank you for your continued patience as we monitor progress. We expect this to be complete by 4pm ET.
Posted Jul 21, 2026 - 11:26 EDT

Update

We are continuing to investigate this issue.
Posted Jul 21, 2026 - 10:49 EDT

Investigating

We have identified an issue affecting the Portfolio History service for requests covering periods prior to June 1, 2026. Our team has identified the underlying cause and is actively working to rectify the issue. We will continue to provide updates as progress is made.
Posted Jul 21, 2026 - 10:49 EDT
This incident affected: Broker API (Portfolio History Endpoint).