Orders placed 2022-08-29 rejected by execution partner
Incident Report for Alpaca
Postmortem

As a follow up to this incident, at approximately 08:00 ET, while reviewing the firm’s order flow, the Alpaca Securities LLC Trading Team determined there was an abnormal quantity of orders being rejected by one of our execution venues.  After reviewing order logs and contacting this venue, the Trading Team was informed by the execution venue that they were experiencing an issue and that Alpaca should route orders away from their venue and not send any new orders until the issue was resolved.

Shortly after receiving this information Alpaca began routing all new orders to other venues. After further communication with the affected venue, they informed us that only orders sent as extended hours = true were impacted. A few minutes after market open (09:30 ET) the venue advised us that the issue was corrected and we could resume sending orders to them for execution.

Out of an abundance of caution Alpaca did not route order flow to this venue until after the core trading session ended at 16:00 ET. All order processing is now normal.

Posted Aug 29, 2022 - 20:13 EDT

Resolved
This incident has been resolved.
Posted Aug 29, 2022 - 08:26 EDT
Investigating
Some orders placed before 8:30 ET Monday 2022-08-29 were rejected by one of Alpaca's execution partners. The issue has been resolved by re-routing to different venues and orders can now be placed normally. However, any rejected orders will need to be re-submitted.
Posted Aug 29, 2022 - 08:25 EDT