Hight Yield Interest Incorrect Amount Posted

Incident Report for Alpaca

Postmortem

On August 31st, a critical operational incident occurred within the FDIC accrual processing system that resulted in duplicate entries being posted to the ledger system.
The incident originated from missed weekend accrual bookings and was compounded by a series of manual intervention attempts that ultimately led to data duplication.
Though the resolution process affected some previously correct transactions. The issue was fully resolved by Monday morning through comprehensive transaction cancellation and rebooking procedures.

Posted Sep 02, 2025 - 16:20 EDT

Resolved

The Incident has been resolved.
Posted Sep 02, 2025 - 16:15 EDT

Update

As The issue has been mitigated for all affected accounts 7:42 AM ET. Our teams are currently working on the root cause analysis, and we will share an update as soon as it is complete.
Posted Sep 01, 2025 - 14:40 EDT

Monitoring

The reversal of all erroneous interest transactions was completed at 4:44PM ET on 8/31.
To ensure the integrity of all account data, our team took the necessary step of canceling all interest transactions posted between August 29th and August 31st.
We initiated the job to re-book the single, correct interest payment for the entire month of August 2025 to all affected accounts. This was complete at 7:42 AM ET on 9/1. You should begin to see these transactions reflected in account activities.
Posted Sep 01, 2025 - 08:54 EDT

Investigating

We're currently investigating an issue where end-of-month interest payments for accounts enrolled in the FDIC program were over-deposited into accounts. Our team is actively working to reverse any duplicate entries and identify the root cause. We will provide updates as we have more information.
Posted Aug 31, 2025 - 13:40 EDT