There was a delay in the posting of reg and taf fees to customers’ accounts that executed a trade on August 30th. These fees were posted on the next business day and will be reflected on September statements.
Incident Report for Alpaca
Resolved
This incident has been resolved.
Posted Sep 06, 2024 - 10:55 EDT
Investigating
We are currently investigating this issue.
Posted Sep 06, 2024 - 10:55 EDT