Issue on Overnight Trading Availability

Incident Report for Alpaca

Postmortem

On July 31, 2026, between approximately 3:15 AM and 4:00 AM ET, customers experienced overnight order rejections after aggregate overnight activity exceeded a capacity control at an execution venue.

Alpaca temporarily paused overnight trading to prevent additional rejections. Normal order processing resumed with the transition to pre-market.

We worked with the venue to increase minimum overnight capacity and improve its intraday adjustment process. Alpaca is also adding pre-breach monitoring and exploring additional overnight execution venue options. We appreciate your patience while service was restored.

Posted Jul 31, 2026 - 12:33 EDT

Resolved

This incident has been resolved.
Posted Jul 31, 2026 - 06:03 EDT

Monitoring

The issue was isolated to the overnight trading session, during which the venue rejected new orders after the notional trading limit was exceeded. With the transition to the pre-market session, the venue is now accepting new orders, and normal order processing has resumed.
Posted Jul 31, 2026 - 04:11 EDT

Identified

We have identified that the issue was caused by the notional trading limit for today's overnight trading session being exceeded. As a result, the trading venue began rejecting new order requests.
Posted Jul 31, 2026 - 04:03 EDT

Investigating

We have temporarily paused overnight trading. Please note that we cannot accept additional overnight orders at this time.
Posted Jul 31, 2026 - 03:33 EDT
This incident affected: Live Trading API (Orders API).