Intermittent Portfolio History Availability

Incident Report for Alpaca

Postmortem

On July 21, 2026, between approximately 4:46 AM and 6:37 AM ET, customers may have experienced intermittent errors for recent Portfolio History requests due to a processing compatibility issue.

Our engineering teams deployed a fix and monitored the service through recovery. Portfolio History request processing is operating normally.

Posted Jul 21, 2026 - 17:13 EDT

Resolved

We have applied necessary fixed and issue is resolved now ,Please reach out to us if still having issue with portfolio history.
Posted Jul 21, 2026 - 06:39 EDT

Identified

We have identified the root cause and currently working toward mitigation.
Posted Jul 21, 2026 - 06:16 EDT

Investigating

We’re investigating an issue causing intermittent errors and missing data for some Portfolio History requests.
The impact appears limited to a subset of recent-date queries, and we’re actively working on a fix.
Posted Jul 21, 2026 - 05:55 EDT
This incident affected: Broker API (Portfolio History Endpoint).