End of day - Balance and position snapshot is delayed for 3-NOV

Incident Report for Alpaca

Postmortem

Incident Summary:

The issue originated early that morning with a delay in our end-of-day job, which impacted balance and position snapshots and led to inaccuracies in several financial calculations. Crucially, this was a display issue only; there was no material impact to the source data or customers' actual funds or positions.

Resolution:

Our team worked in stages to restore services, first resolving all functionality for withdrawable cash and settled cash. This restored functionality while also enhancing operating levels. Concurrently with the remediation, we proactively upgraded the database to significantly boost capacity, stability, and speed. This not only restored functionality but also resulted in enhanced operational levels.

We can now confirm that the final data synchronization process, initiated after the close of trading hours on November 4, completed successfully. This has restored full accuracy to all account balances and the following figures:

  • Day Trading Buying Power
  • Pattern Day Trading limits
  • Margin Multiplier calculations
  • Displayed Interest Rates

All services are now operating normally.

We sincerely apologize for the disruption this has caused to your business and clients. We appreciate your patience as we worked to complete this resolution.

Posted Nov 06, 2025 - 19:14 EST

Resolved

Following the final system resynchronisation process yesterday, all related jobs ran successfully, and no further issues were observed. We are marking this incident as resolved and will share a detailed root cause analysis and postmortem shortly.
Posted Nov 05, 2025 - 11:19 EST

Monitoring

Full Balance and Buying Power Accuracy Restored

We are happy to confirm that the final system resynchronization process has successfully completed.
All client balances, Buying Power, Margin Multiplier, and Interest Rate calculations are now accurate and fully restored.

We sincerely appreciate your patience throughout this extended incident. Our team is now actively monitoring all affected systems to ensure stability and to prevent recurrence.
Posted Nov 04, 2025 - 17:43 EST

Update

The critical system resync to fix client balances and Buying Power is now running. We anticipate a temporary impact on account creation, but all new requests are being queued and will be processed immediately once the sync is complete.
Posted Nov 04, 2025 - 16:35 EST

Update

Our engineering team has successfully identified and validated the final fix required to restore accurate balances and Buying Power figures.

Action Plan: To avoid any interruption to live trading, we will initiate the final data synchronization process after the close of trading hours today. This process is confirmed to restore accuracy for account balances and all Buying Power figures.

Temporary Impact During Sync: Please note that Account Creation will be temporarily queued (for approximately one hour) while the system performs the final sync. All other core services will remain operational.

We will update this page immediately once the sync is complete and all figures are fully restored.
Posted Nov 04, 2025 - 14:57 EST

Update

We confirm that withdrawable cash and settled cash functionality have been fully resolved and are working normally.
Our engineering team is still focused on the final dependent issues related to account calculations. We are actively working to restore the accuracy and availability of the following figures:

1. Day Trading Buying Power
2. Pattern Day Trading limits
3. Margin Multiplier calculations
4. Displayed Interest Rates

We appreciate your continued patience as we work through these final fixes.
Posted Nov 04, 2025 - 12:42 EST

Update

The necessary position sync is complete, and we confirm that cash is now withdrawable for all clients.

Our engineering team is now focused on resolving the remaining issues that impact financial calculations. We are working to restore accuracy for:

1. Day Trading and Pattern Day Trading Buying Power.
2. Margin Multiplier.
3. Up-to-date Interest Rates.

Thank you for your continued patience.
Posted Nov 04, 2025 - 11:03 EST

Update

We are prioritizing the completion of a necessary process to restore the ability to withdraw cash.

Important Note: While we work to resolve the withdrawal issue, the following figures will temporarily remain unreliable or outdated:

1. Day Trading Buying Power
2. Pattern Day Trading limits
3. Margin Multiplier calculations.
4. Displayed Interest Rates.


Thank you for your continued patience.
Posted Nov 04, 2025 - 10:11 EST

Update

Our team is still actively investigating the issue impacting cash withdrawals and Buying Power accuracy.

Impacted Functions Remain:

1. Inability to withdraw cash.
2. Stale or inaccurate Buying Power information.

We understand the severity of this issue and are working with the highest urgency to isolate the root cause and deploy a fix.
Posted Nov 04, 2025 - 09:39 EST

Update

Position update completed. Balance calculation still running.
Posted Nov 04, 2025 - 07:08 EST

Identified

We are rerunning the job after rollback
Posted Nov 04, 2025 - 06:23 EST

Investigating

Our end of day job is running longer than expected. This will impact the balance and position snapshot for the 3-NOV, 2025.
Account activation will be delayed.
Posted Nov 04, 2025 - 03:39 EST
This incident affected: Accounts (Transfers).