Duplicated dividends processed for asset AAPL

Incident Report for Alpaca

Resolved

This incident has been resolved.
Posted Nov 13, 2025 - 13:17 EST

Monitoring

The duplicated dividends entries are cancelled and balances are adjusted. This would have caused change in balances. SSE events are also being pushed for cancellation.
Posted Nov 13, 2025 - 13:16 EST

Identified

We have identified that dividend payouts for asset AAPL were duplicated while processing
Posted Nov 13, 2025 - 13:14 EST

Investigating

We are currently investigating this issue.
Posted Nov 13, 2025 - 13:13 EST
This incident affected: Broker API (broker.accounts.activities.get).