Double booked REG and TAF fees for trading day May 02
Incident Report for Alpaca
Resolved
This incident has been resolved.
Posted May 03, 2024 - 07:53 EDT
Identified
REG and TAF fees were mistakenly double booked during our end of day process for the day May 02. We are working on the fix and the double booked fees will be canceled shortly. This affects all accounts with equity trade activity on May 02.
Posted May 03, 2024 - 04:47 EDT