Delay in posting high-yield sweep interest accruals

Incident Report for Alpaca

Resolved

This incident has been resolved.
Posted Aug 14, 2025 - 23:00 EDT

Identified

The issue has been identified and a fix is being implemented.
Posted Aug 14, 2025 - 17:52 EDT

Investigating

We are currently experiencing a delay in the posting of high-yield sweep interest accrual entries. Please be assured that this will not affect the actual interest accruals or your monthly payments. We will provide an update as soon as the records have been processed.
Posted Aug 14, 2025 - 17:51 EDT