Divs and other CA's payable on or about 1/15 may be late in processing
Incident Report for Alpaca
Resolved
Divs and other CA's payable on or about 1/15 may be late in processing. We have resolved the issue that instigated this delay, and all payouts should be completed by the end of today.
Posted Jan 20, 2022 - 07:43 EST
Monitoring
Divs and other CA's payable on or about 1/15 may be late in processing. We have resolved the issue that instigated this delay, and all payouts should be completed by the end of today.
Posted Jan 20, 2022 - 07:42 EST